Back to overview
Resolved

Degraded response times

May 22, 2026 at 9:58am UTC
Affected services
Manually tracked item

Resolved
May 22, 2026 at 9:58am UTC

Hello,

We experienced slowdowns in Prod 1 services following a technical incident affecting our hosting provider's data center at 11:09 AM.

Our technical teams mobilized immediately, and the situation has now been resolved.

We apologize for any inconvenience and thank you for your understanding.

The Easylience Team